I'm getting an error though I can connect on port 27000

vagrant@m103:/data/db$ validate_lab_first_application_user

Client experienced a timeout when connecting to the database - check that mongod
is running on the correct port, and that the ‘m103-application-user’ user
authenticates against the admin database.

vagrant@m103:/data/db$ mongo admin -u m103-application-user -p m103-application-user --port
27000
MongoDB shell version v3.6.10
connecting to: mongodb://127.0.0.1:27000/admin?gssapiServiceName=mongodb
Implicit session: session { “id” : UUID(“945d16bd-49e3-4d1a-9e6d-9f55356a269b”) }
MongoDB server version: 3.6.10
MongoDB Enterprise >

root@m103:/etc# ps -aef | grep mongod | grep -v grep
netstat -tlnp | grep mongodvagrant 16518 1 0 02:45 ? 00:00:05 mongod -f /etc/mongod.conf
root@m103:/etc# netstat -tlnp | grep mongod
tcp 0 0 192.168.103.100:27000 0.0.0.0:* LISTEN 16518/mongod
tcp 0 0 127.0.0.1:27000 0.0.0.0:* LISTEN 16518/mongod

root@m103:/etc# egrep -v ‘^#|^$’ mongod.conf
storage:
dbPath: “/var/mongodb/db”
journal:
enabled: true
systemLog:
destination: file
logAppend: true
path: “/var/mongodb/db/mongod.log”
net:
port: 27000
bindIp : “127.0.0.1,192.168.103.100”
processManagement:
timeZoneInfo: /usr/share/zoneinfo
fork : true
security:
authorization: enabled

1 Like

You specify m103-application-user as the password which is probably wrong.

1 Like

Not probably - definitely is wrong. I messed with this for an hour trying to figure out what was wrong. I used db.changeUserPassword to correct it and it worked.

Thanks a ton Steevej-1495!

4 Likes