I still can't get the vagrant up with the following error message

Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Box ‘ubuntu/trusty64’ could not be found. Attempting to find and install…
mongod-m103: Box Provider: virtualbox
mongod-m103: Box Version: >= 0
==> mongod-m103: Loading metadata for box ‘ubuntu/trusty64’
mongod-m103: URL: https://vagrantcloud.com/ubuntu/trusty64
==> mongod-m103: Adding box ‘ubuntu/trusty64’ (v20190429.0.1) for provider: virtualbox
mongod-m103: Downloading: https://vagrantcloud.com/ubuntu/boxes/trusty64/versions/20190429.0.1/providers/virtualbox.box
==> mongod-m103: Box download is resuming from prior download progress
mongod-m103: Download redirected to host: cloud-images.ubuntu.com
mongod-m103: Progress: 100% (Rate: 106/s, Estimated time remaining: --:–:--An error occurred while downloading the remote file. The error
message, if any, is reproduced below. Please fix this error and try
again.

transfer closed with 328417280 bytes remaining to read

Hi @David_00619,

Please make sure you don’t have any firewall enabled and are not using any Internet security software.

If already checked, please try the below given solution:

Use the command “vagrant init” to reset the configuration of Vagrantfile

You may also refer to the following thread and see if it helps.

Thanks,
Muskan
Curriculum Support Engineer

Hi @David_00619,

Please perform the following steps to bring up the vagrant environment:

  • Check if your internet connection is stable.
  • You can try removing the “.vagrant.d/tmp/” directory and then restart the vagrant up from within the m103-vagrant-env directory as follows:

    vagrant up --provision

  • If the above steps do not resolve the issue, please uninstall vagrant and start the set up process from beginning.

You can refer to the Vagrant&VirtualBox doc for your OS from Handouts in Lecture: Setting up the Vagrant Environment for the detailed instructions on downloading and setting up Vagrant.

Please let me know, if you have any questions.

Thanks,
Sonali