HW 2.6 Cannot ssh to Inrastructure

I used to be able to ssh to infrastructure machine beofre (as in LDAP exercise where I had to use infrastructure to run ldap server).

For this exercise very time I try ssh I get this:


I already tried to destroy vagrant, clean directories, reload the machine, nothing helps. End result as in the screen.

This is after destroying and reloading the VMs

What is the issue?

Hello? Anybody home?

Are you still facing issues?
In your screenshot after plugin install you were trying to ssh
Is vagrant up?
There are some suggestions for no guest additions were detected error

Are you using cmd line or power shell?
set VAGRANT_PREFER_SYSTEM_BIN=0
vagrant destroy infrastructure -f
vagrant up infrastructure

Another thread talsk about power shell vs command prompt
To update path variable with VAGRANT_PREFER_SYSTEM_BIN etc

or it could be version related issues

I did as described in the other post and it worked. Copying over that guy’s resolution:

mandeep_60793

1

Apr 28

Hello

I managed to hack around the issue.
After running “vagrant up infrastructure” a second time i had a vm that was up and running, but no shared folder.

once infrastructure was up but no shared folder, i ssh to infrastructure and ran as below:

sudo yum update -y

Then once that completed I disconnected from ssh and re-ran
vagrant plugin install vagrant-vbguest
“vagrant reload infrastructure”
“vagrant up infrastructure --provision”

I now have a vm with shared folder.