HW-1.3: Connected to the MONGOD instance, but unable to make rs.initiate() work

Is there anybody to give me pointers for resolving my problem. The content of the log file, except the removed ‘Options…’ line, is as follows:

2019-12-25T18:24:52.150+0000 I CONTROL [initandlisten] MongoDB starting : pid=5674 port=31130 dbpath=/home/vagrant/M310-HW-1.3/r0 64-bit host=database
2019-12-25T18:24:52.150+0000 I CONTROL [initandlisten] db version v3.2.22
2019-12-25T18:24:52.151+0000 I CONTROL [initandlisten] git version: 105acca0d443f9a47c1a5bd608fd7133840a58dd
2019-12-25T18:24:52.151+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1f 6 Jan 2014
2019-12-25T18:24:52.151+0000 I CONTROL [initandlisten] allocator: tcmalloc
2019-12-25T18:24:52.151+0000 I CONTROL [initandlisten] modules: enterprise
2019-12-25T18:24:52.151+0000 I CONTROL [initandlisten] build environment:
2019-12-25T18:24:52.151+0000 I CONTROL [initandlisten] distmod: ubuntu1404
2019-12-25T18:24:52.151+0000 I CONTROL [initandlisten] distarch: x86_64
2019-12-25T18:24:52.151+0000 I CONTROL [initandlisten] target_arch: x86_64
2019-12-25T18:24:52.170+0000 I - [initandlisten] Detected data files in /home/vagrant/M310-HW-1.3/r0 created by the ‘wiredTiger’ storage engine, so setting the active storage engine to ‘wiredTiger’.
2019-12-25T18:24:52.171+0000 I STORAGE [initandlisten] wiredtiger_open config: create,cache_size=1G,session_max=20000,eviction=(threads_min=4,threads_max=4),config_base=false,statistics=(fast),log=(enabled=true,archive=true,path=journal,compressor=snappy),file_manager=(close_idle_time=100000),checkpoint=(wait=60,log_size=2GB),statistics_log=(wait=0),verbose=(recovery_progress),
2019-12-25T18:24:52.276+0000 I STORAGE [initandlisten] WiredTiger [1577298292:276774][5674:0x7fd8e4682d00], txn-recover: Main recovery loop: starting at 1/15104
2019-12-25T18:24:52.353+0000 I STORAGE [initandlisten] WiredTiger [1577298292:353738][5674:0x7fd8e4682d00], txn-recover: Recovering log 1 through 2
2019-12-25T18:24:52.405+0000 I STORAGE [initandlisten] WiredTiger [1577298292:405151][5674:0x7fd8e4682d00], txn-recover: Recovering log 2 through 2
2019-12-25T18:24:52.460+0000 I CONTROL [initandlisten]
2019-12-25T18:24:52.460+0000 I CONTROL [initandlisten] ** WARNING: /sys/kernel/mm/transparent_hugepage/enabled is ‘always’.
2019-12-25T18:24:52.460+0000 I CONTROL [initandlisten] ** We suggest setting it to ‘never’
2019-12-25T18:24:52.460+0000 I CONTROL [initandlisten]
2019-12-25T18:24:52.460+0000 I CONTROL [initandlisten] ** WARNING: /sys/kernel/mm/transparent_hugepage/defrag is ‘always’.
2019-12-25T18:24:52.460+0000 I CONTROL [initandlisten] ** We suggest setting it to ‘never’
2019-12-25T18:24:52.460+0000 I CONTROL [initandlisten]
2019-12-25T18:24:52.477+0000 I REPL [initandlisten] Did not find local voted for document at startup.
2019-12-25T18:24:52.477+0000 I REPL [initandlisten] Did not find local replica set configuration document at startup; NoMatchingDocument: Did not find replica set configuration document in local.system.replset
2019-12-25T18:24:52.477+0000 I FTDC [initandlisten] Initializing full-time diagnostic data capture with directory ‘/home/vagrant/M310-HW-1.3/r0/diagnostic.data’
2019-12-25T18:24:52.477+0000 I NETWORK [initandlisten] waiting for connections on port 31130 ssl
2019-12-25T18:24:52.477+0000 I NETWORK [HostnameCanonicalizationWorker] Starting hostname canonicalization worker
2019-12-25T18:26:32.429+0000 I NETWORK [initandlisten] connection accepted from 127.0.0.1:41658 #1 (1 connection now open)
2019-12-25T18:26:32.435+0000 I ACCESS [conn1] note: no users configured in admin.system.users, allowing localhost access
2019-12-25T18:26:32.438+0000 I ACCESS [conn1] Unauthorized: not authorized on admin to execute command { getLog: “startupWarnings” }
2019-12-25T18:26:53.915+0000 I COMMAND [conn1] initiate : no configuration specified. Using a default configuration for the set
2019-12-25T18:26:53.915+0000 I COMMAND [conn1] created this configuration for initiation : { _id: “replSet-113”, version: 1, members: [ { _id: 0, host: “database.m310.mongodb.university:31130” } ] }
2019-12-25T18:26:53.915+0000 I REPL [conn1] replSetInitiate admin command received from client
2019-12-25T18:26:53.916+0000 I NETWORK [initandlisten] connection accepted from 127.0.0.1:52485 #2 (2 connections now open)
2019-12-25T18:26:53.921+0000 I ACCESS [conn2] authenticate db: $external { authenticate: 1, mechanism: “MONGODB-X509”, user: “C=US,ST=New York,L=New York City,O=MongoDB,OU=University,CN=M310 Server” }
2019-12-25T18:26:53.921+0000 I ACCESS [conn2] Failed to authenticate C=US,ST=New York,L=New York City,O=MongoDB,OU=University,CN=M310 Server@$external with mechanism MONGODB-X509: UserNotFound: Could not find user C=US,ST=New York,L=New York City,O=MongoDB,OU=University,CN=M310 Server@$external
2019-12-25T18:26:53.921+0000 I NETWORK [conn1] can’t authenticate to database.m310.mongodb.university:31130 (127.0.1.1) as internal user, error: Could not find user C=US,ST=New York,L=New York City,O=MongoDB,OU=University,CN=M310 Server@$external
2019-12-25T18:26:53.921+0000 E REPL [conn1] replSet initiate got NodeNotFound: No host described in new configuration 1 for replica set replSet-113 maps to this node while validating { _id: “replSet-113”, version: 1, members: [ { _id: 0, host: “database.m310.mongodb.university:31130” } ] }
2019-12-25T18:26:53.923+0000 I NETWORK [conn2] end connection 127.0.0.1:52485 (1 connection now open)
2019-12-25T18:31:29.471+0000 I NETWORK [conn1] end connection 127.0.0.1:41658 (0 connections now open)

This is resolved by understanding all certificates and their purposes

1 Like