How to install compass Ubuntu 18.10

i Downloaded compass for ubuntu but if i click on it to run it nothing happens how do i go about it?

You will need to install it first :slight_smile:

The download should be a .deb file, right? You need to install it with “dpkg” first.

i’ve done so but if i click on lunch nothing happens

sudo dpkg -i /home/will/Downloads/mongodb-compass.deb 
Selecting previously unselected package mongodb-compass.
(Reading database ... 154020 files and directories currently installed.)
Preparing to unpack .../Downloads/mongodb-compass.deb ...
Unpacking mongodb-compass (1.15.4-1) ...
Setting up mongodb-compass (1.15.4-1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu2) ...
Processing triggers for desktop-file-utils (0.23-3ubuntu2) ...
Processing triggers for mime-support (3.60ubuntu1) ...

That is odd… Launching it should really start it. Let’s try this instead…

  1. Open a new terminal window
  2. Type “mongodb-compa” and press the TAB key.
  3. This should autocomplete to a name such as “mongodb-compass-community”, or something similar.
  4. Press enter to fire up the tool.

This should start Compass. And with any luck the terminal screen will also include some logging to show what’s going wrong.

mongodb-compa
~$ mongodb-compass
Segmentation fault (core dumped)

OOOFF, that’s a bad one. That’s a big, fat crash right there. A segfault is when an application tries to access a piece of memory that doesn’t belong to it. Seems that the Compass installation didn’t go correctly, or you installed a wrong version (like 64-bit on a 32-bit system).

i’m using a 64 bit system

@Will_12128,

Sorry you are having issues. I’m going to reach out to the Compass team to see if they have any info on this.

I’d ask you not to delete the core file! It may prove very useful to our Compass team.

1 Like

Hello, have u solved that problem? On Ubuntu forums is reported that for whatever reason Compass versions from 14 up dont work on Ubuntu 18 while compass 14 and previous go perfectly. The problem is that Mongo server doesnt allow to download versions before 15…