Homework 2.6 : Configure KMIP backed mongod

mongod --dbpath ~/M310-HW-2.6/ --logpath ~/M310-HW-2.6/HW.log --enableEncryption --kmipServerName infrastrcuture.m310.mongodb.university --kmipServerCAFile ~/shared/certs/ca.pem --kmipClientCertificateFile ~/shared/certs/client.pem --port 31260
2019-09-30T15:35:27.026+0000 I CONTROL [main] log file “/home/vagrant/M310-HW-2.6/HW.log” exists; moved to “/home/vagrant/M310-HW-2.6/HW.log.2019-09-30T15-35-27”.

I have removed the directory M310-HW-2.6 and again recreate it but still getting same error.
Please suggest

It is not error just a warning message
Is your mongod with KMIP up and running or not?
If you don’t want to see this message remove old logfile or use
logAppend: true
The message says an existing logfile with same name already exists so it is moving to a different name with timestamp appended

1 Like

Hi @baishakhi_81883,

Please do as @Ramachandra_37567’s suggestion, let me know if it does not help.

Kanika

I understood that the error is due to log file name existence but i have deleted the whole folder and recreate it but it is giving error when used with fork as error number 14.

Please suggest

It worked now , i have killed all the mongod process running and restarted mongod with all the config

Thanks

1 Like