Homework 1.3 Name of RS?

What should name the replicat set?

The replicat set name is part of the output of the command validate-hw-1.3.sh. But I couldn’t find the RS name in the assignment?

The script validate-hw-1.3.sh returns a very long string which contains the RS name.

Or the replicat set name doesn’t matter.

Replicaset name should not matter if nothing mentioned in the lab
You can give any name of your choice

Hi Ramachandra,

Thank you so much for your reply. I have finished every step successfully and got the below output but it failed.

Can you please take a quick look? Thank you so much! I really appreciate your help.

vagrant@database:~/shared$ ./validate-hw-1.3.sh

{ unauthorizedStatus: {“set”:“TO_BE_SECURED”,“date”:“2019-06-23T19:03:11.607Z”,“myState”:1,“term”:{“floatApprox”:1},“heartbeatIntervalMillis”:{“floatApprox”:2000},“members”:[{"_id":0,“name”:“database.m310.mongodb.university:31130”,“health”:1,“state”:1,“stateStr”:“PRIMARY”,“uptime”:2806,“optime”:{“ts”:{“t”:1561315985,“i”:4},“t”:{“floatApprox”:1}},“optimeDate”:“2019-06-23T18:53:05.000Z”,“electionTime”:{“t”:1561314921,“i”:2},“electionDate”:“2019-06-23T18:35:21.000Z”,“configVersion”:3,“self”:true},{"_id":1,“name”:“database.m310.mongodb.university:31131”,“health”:1,“state”:2,“stateStr”:“SECONDARY”,“uptime”:1599,“optime”:{“ts”:{“t”:1561315985,“i”:4},“t”:{“floatApprox”:1}},“optimeDate”:“2019-06-23T18:53:05.000Z”,“lastHeartbeat”:“2019-06-23T19:03:11.317Z”,“lastHeartbeatRecv”:“2019-06-23T19:03:11.317Z”,“pingMs”:{“floatApprox”:0},“syncingTo”:“database.m310.mongodb.university:31130”,“configVersion”:3},{"_id":2,“name”:“database.m310.mongodb.university:31132”,“health”:1,“state”:2,“stateStr”:“SECONDARY”,“uptime”:1593,“optime”:{“ts”:{“t”:1561315985,“i”:4},“t”:{“floatApprox”:1}},“optimeDate”:“2019-06-23T18:53:05.000Z”,“lastHeartbeat”:“2019-06-23T19:03:11.134Z”,“lastHeartbeatRecv”:“2019-06-23T19:03:11.299Z”,“pingMs”:{“floatApprox”:0},“syncingTo”:“database.m310.mongodb.university:31131”,“configVersion”:3}],“ok”:1},
memberStatuses: [“PRIMARY”,“SECONDARY”,“SECONDARY”] }

Yes your output is not correct

Did you create certificate files,enabled x509 authentication etc
You need to create users also.Are you able to login with that user?
It depends on how you started your mongod and connecting mongo (options you use to start mongod and mongo)

Please review your steps again