HELP! Virtualbox Issue

I thought if I started over from scratch it would help. Now I am getting the following:

PS C:\Users\debra> cd C:\Users\debra\university\m103\m103-vagrant-env
PS C:\Users\debra\university\m103\m103-vagrant-env> vagrant up --provision
Bringing machine ‘mongod-m103’ up with ‘virtualbox’ provider…
==> mongod-m103: Setting the name of the VM: mongod-m103
The name of your virtual machine couldn’t be set because VirtualBox
is reporting another VM with that name already exists. Most of the
time, this is because of an error with VirtualBox not cleaning up
properly. To fix this, verify that no VMs with that name do exist
(by opening the VirtualBox GUI). If they don’t, then look at the
folder in the error message from VirtualBox below and remove it
if there isn’t any information you need in there.

VirtualBox error:

VBoxManage.exe: error: Could not rename the directory ‘C:\Users\debra\VirtualBox VMs\ubuntu-cloudimg-trusty-vagrant-amd64_1555221718259_93382’ to ‘C:\Users\debra\VirtualBox VMs\mongod-m103’ to save the settings file (VERR_ALREADY_EXISTS)
VBoxManage.exe: error: Details: code E_FAIL (0x80004005), component SessionMachine, interface IMachine, callee IUnknown
VBoxManage.exe: error: Context: “SaveSettings()” at line 3194 of file VBoxManageModifyVM.cpp
PS C:\Users\debra\university\m103\m103-vagrant-env>

What is the error when you do vagrant ssh ?

You need to run vagrant destroy. Then Check vagrant global-status and if mongod-m103 appears, then run vagrant destroy <ID>. is the value of the first column.

Kanika

If you are on Windows 10 Pro with Hyper-V Enabled, disable Hyper-V using bcdedit and try again. Google it :slight_smile:

1 Like

That helped. Thank you!