Watch keynotes and sessions from MongoDB.live, our virtual developer conference.

FLE MongoError: BSON field 'insert.jsonSchema' is an unknown field

Hi Everyone!
After seeing the Field level encryption on a session of Mongo DB live we decided to try implementing it.
I successfully generated the key vault collection using a AWS KMS key. Next I followed the docs and added a JSON schema to the collection which also worked and I can see the schema in compass. Now what I cant seem to get working is the actual insert. Everything I have tried gives the following error on insert
"MongoError: BSON field ‘insert.jsonSchema’ is an unknown field. "
What exactly does this error mean with FLE?

I am actually working with dev support now, and they are looking into it.

Hi @kyle_mcarthur, and welcome to the forum!

The error message sounds related to a misconfiguration on the application side.
You may find the following resources useful:

Feel free to post back here if you have a solution. It may beneficial for other users who may encounter similar configuration issue in the future.

Regards,
Wan.