Watch keynotes and sessions from MongoDB.live, our virtual developer conference.

Fail to connect to local server after restarting Mac pro

I try to connect to database to local port using /Users/charles/mongodb/bin/mongod —-dbpath=/charles/mongodb-data. Error returned
Automatically disabling TLS 1.0, to force-enable TLS 1.0 specify --sslDisabledProtocols ‘none’
No TransportLayer configured during NetworkInterface startup
Invalid command: —-dbpath=/charles/mongodb-data
But i can see that --dbpath is clearly a storage options as seen in the options menu
–dbpath arg Directory for datafiles - defaults to
/data/db
This was working perfectly for 6 months since i started working with the mongodb community server and the command just stopped working after i restarted my computer esterday

It might be the markup language for this forum but the first dash seems odd. There is clear difference between the dash dash of your command

and the dash dash of the sentence

The first dash of the command is longer.

1 Like

Thanks you are right