Errortype: 'mongorestore' is not recognized as an internal or external command, operable program or batch file or Failed: error connecting to db server: server returned error on SASL authentication step: bad auth Authentication failed

1.Direct to “c:\Program Files\MongoDB\Server\4.0\bin”
command prompt line.
2.Type below statement in command prompt line.
Instead of *****, you give your cluster name.
(from cluster ==>Connect).I stored mflix-js in
D drive.So I gave the path as D:\MongoDBUni\mflix-js\data

mongorestore --drop --gzip --host mflix-shard-0/
mflix-shard-00-00-.mongodb.net:27017,
mflix-shard-00-01-
.mongodb.net:27017,
mflix-shard-00-02-*****.mongodb.net:27017
-ssl --username m220student
–password m220student
D:\MongoDBUni\mflix-js\data

=======================================

Hi @Anuja_05255,

Please share the command for mongorestore with your connection uri.

Kanika

Thanks.Its working now

but i encountered another issue in npm start. it shown authorization failed. I created login credentials with admin and normal user. please help me on this

no issues. its working now. I deleted the IP whitelist and created again with connect from anywhere option.And relogin to cluster.

Thank you