Error when installing Python Library Dependencies

Getting error when installing the requirements for the course.

Am running this command:
C:\university\m220\mflix-python>activate mflix

(mflix) C:\university\m220\mflix-python>pip install -r requirements.txt
You are using pip version 7.0.1, however version 18.1 is available.
You should consider upgrading via the ‘pip install --upgrade pip’ command.
Collecting Flask==0.12.4 (from -r requirements.txt (line 1))
Downloading https://files.pythonhosted.org/packages/2e/48/f1936dadac2326b3d73f2fe0a964a87d16be16eb9d7fc56f09c1bea3d17c/Flask-0.12.4-py2.py3-none-any.whl (81kB)
100% |################################| 81kB 182kB/s
Collecting Flask-Bcrypt==0.7.1 (from -r requirements.txt (line 2))
Downloading https://files.pythonhosted.org/packages/1d/c0/6d4c04d007d72b355de24e7a223978d1a95732245f9e9becbf45d3024bf8/Flask-Bcrypt-0.7.1.tar.gz



Collecting ipykernel (from jupyter==1.0.0->-r requirements.txt (line 10))
Downloading https://files.pythonhosted.org/packages/11/0b/95330660f8cc5d63428b9886c800ea8d68842fd866389cf579acca4915be/ipykernel-5.1.0.tar.gz (101kB)
100% |################################| 102kB 890kB/s
Complete output from command python setup.py egg_info:
ERROR: ipykernel requires Python version 3.4 or above.

----------------------------------------

Command “python setup.py egg_info” failed with error code 1 in c:\users\pchukw~1\appdata\local\temp\pip-build-vpytkd\ipykernel

(mflix) C:\university\m220\mflix-python>

I think you should install the latest version of python first

Note i have sorted this out.

Solution:
i had python 2.7 32bit installed on my laptop. i downloaded the latest python 3.7 but it downloaded 32bit again meanwhile my laptop is 64bit. So after installing the python 3.7, when i checked version status(python --version), it is still showing python 2.7.
so google how to download python for 64bit windows, and i followed the steps and downloaded and installed the python for 64bit windows. check then restart my laptop and check status again and it showed the latest version installed which is python 3.7.
Then i ran the command to install the requirements for the course(pip install -r requirements.txt).
Then, i ran the python run.py and it worked fine this time without error.

c:\university\m220\mflix-python>python run.py

  • Restarting with stat
  • Debugger is active!
  • Debugger PIN: 321-451-220
  • Running on http://xxx.x.x.x:xxxx/ (Press CTRL+C to quit)
    127.0.0.1 - - [21/Oct/2018 00:55:51] “GET / HTTP/1.1” 200 -
    127.0.0.1 - - [21/Oct/2018 00:55:51] “GET /static/css/main.61f16bdd.css HTTP/1.1” 200 -
    127.0.0.1 - - [21/Oct/2018 00:55:51] “GET /static/js/main.a4491d28.js HTTP/1.1” 200 -
    127.0.0.1 - - [21/Oct/2018 00:56:04] “GET /static/media/mongoleaf.0ebc1843.png HTTP/1.1” 200 -
    127.0.0.1 - - [21/Oct/2018 00:56:04] “GET /service-worker.js HTTP/1.1” 200 -
    127.0.0.1 - - [21/Oct/2018 00:56:04] “GET /favicon.ico HTTP/1.1” 200 -
    127.0.0.1 - - [21/Oct/2018 00:56:17] “GET /api/v1/movies/ HTTP/1.1” 200 -
    127.0.0.1 - - [21/Oct/2018 00:59:56] “GET /favicon.ico HTTP/1.1” 200 -
    127.0.0.1 - - [21/Oct/2018 01:00:32] “GET /favicon.ico HTTP/1.1” 200 -
    127.0.0.1 - - [21/Oct/2018 01:00:32] “OPTIONS /api/v1/user/login HTTP/1.1” 200 -
    127.0.0.1 - - [21/Oct/2018 01:00:38] “GET /api/v1/movies/ HTTP/1.1” 200 -
    127.0.0.1 - - [21/Oct/2018 01:00:44] “POST /api/v1/user/login HTTP/1.1” 401 -

thanks all for your contribution

1 Like