Error when I try to run NPM INSALL, please anyone help me?

Dev@Developer MINGW64 /e/portfolio-apps/mflix-js
$ npm install

weak-napi@1.0.3 install E:\portfolio-apps\mflix-js\node_modules\weak-napi
node-gyp rebuild

E:\portfolio-apps\mflix-js\node_modules\weak-napi>if not defined npm_config_node_gyp (node “C:\Users\Dev\AppData\Roaming\npm\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin\…\node_modules\node-gyp\bin\node-gyp.js” rebuild ) else (node “C:\Users\Dev\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” rebuild )
gyp ERR! find Python
gyp ERR! find Python Python is not set from command line or npm configuration
gyp ERR! find Python Python is not set from environment variable PYTHON
gyp ERR! find Python checking if “python” can be used
gyp ERR! find Python - “python” is not in PATH or produced an error
gyp ERR! find Python checking if “python2” can be used
gyp ERR! find Python - “python2” is not in PATH or produced an error
gyp ERR! find Python checking if the py launcher can be used to find Python 2
gyp ERR! find Python - “py.exe” is not in PATH or produced an error
gyp ERR! find Python checking if Python is C:\Python27\python.exe
gyp ERR! find Python - “C:\Python27\python.exe” could not be run
gyp ERR! find Python checking if Python is C:\Python37\python.exe
gyp ERR! find Python - “C:\Python37\python.exe” could not be run
gyp ERR! find Python
gyp ERR! find Python **********************************************************
gyp ERR! find Python You need to install the latest version of Python 2.7.
gyp ERR! find Python Node-gyp should be able to find and use Python. If not,
gyp ERR! find Python you can try one of the following options:
gyp ERR! find Python - Use the switch --python=“C:\Path\To\python.exe”
gyp ERR! find Python (accepted by both node-gyp and npm)
gyp ERR! find Python - Set the environment variable PYTHON
gyp ERR! find Python - Set the npm configuration variable python:
gyp ERR! find Python npm config set python “C:\Path\To\python.exe”
gyp ERR! find Python For more information consult the documentation at:
gyp ERR! find Python https://github.com/nodejs/node-gyp#installation
gyp ERR! find Python **********************************************************
gyp ERR! find Python
gyp ERR! configure error
gyp ERR! stack Error: Could not find any Python installation to use
gyp ERR! stack at PythonFinder.fail (C:\Users\Dev\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\lib\find-python.js:303:47)
gyp ERR! stack at PythonFinder.runChecks (C:\Users\Dev\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\lib\find-python.js:132:21)
gyp ERR! stack at PythonFinder. (C:\Users\Dev\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\lib\find-python.js:221:16)
gyp ERR! stack at PythonFinder.execFileCallback (C:\Users\Dev\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\lib\find-python.js:267:16)
gyp ERR! stack at exithandler (child_process.js:301:5)
gyp ERR! stack at ChildProcess.errorhandler (child_process.js:313:5)
gyp ERR! stack at ChildProcess.emit (events.js:198:13)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:246:12)
gyp ERR! stack at onErrorNT (internal/child_process.js:415:16)
gyp ERR! stack at process._tickCallback (internal/process/next_tick.js:63:19)
gyp ERR! System Windows_NT 10.0.17763
gyp ERR! command “C:\Program Files\nodejs\node.exe” “C:\Users\Dev\AppData\Roaming\npm\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
gyp ERR! cwd E:\portfolio-apps\mflix-js\node_modules\weak-napi
gyp ERR! node -v v10.16.3
gyp ERR! node-gyp -v v5.0.3
gyp ERR! not ok
npm WARN eslint-config-react-app@2.1.0 requires a peer of babel-eslint@^7.2.3 but none is installed. You must install peer dependencies yourself.
npm WARN eslint-config-react-app@2.1.0 requires a peer of eslint-plugin-jsx-a11y@^5.1.1 but none is installed. You must install peer dependencies yourself.
npm WARN server@1.0.0 No repository field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.9 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.9: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})

npm ERR! Maximum call stack size exceeded

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\Dev\AppData\Roaming\npm-cache_logs\2019-10-16T05_16_28_642Z-debug.log

Dev@Developer MINGW64 /e/portfolio-apps/mflix-js
$ npm start

server@1.0.0 start E:\portfolio-apps\mflix-js
nodemon -L ./index.js

[nodemon] 1.19.1
[nodemon] to restart at any time, enter rs
[nodemon] watching: .
[nodemon] starting node ./index.js
MongoParseError: URI malformed, cannot be parsed
at parseConnectionString (E:\portfolio-apps\mflix-js\node_modules\mongodb\lib\core\uri_parser.js:502:21)
at connect (E:\portfolio-apps\mflix-js\node_modules\mongodb\lib\operations\connect.js:266:3)
at ConnectOperation.execute (E:\portfolio-apps\mflix-js\node_modules\mongodb\lib\operations\connect.js:191:5)
at E:\portfolio-apps\mflix-js\node_modules\mongodb\lib\operations\execute_operation.js:109:26
at new Promise ()
at executeOperation (E:\portfolio-apps\mflix-js\node_modules\mongodb\lib\operations\execute_operation.js:102:10)
at MongoClient.connect (E:\portfolio-apps\mflix-js\node_modules\mongodb\lib\mongo_client.js:216:10)
at Function.MongoClient.connect (E:\portfolio-apps\mflix-js\node_modules\mongodb\lib\mongo_client.js:379:22)
at Object.connect (E:\portfolio-apps\mflix-js\src/index.js:23:13)
at Module._compile (internal/modules/cjs/loader.js:778:30)
[nodemon] app crashed - waiting for file changes before starting…

Hi @Hashim_69647,

This is a known error and it will not halt any process.

Please check the URI string in the configuration file: .env file.

Kanika

Kanika thanks for the assistance.
Can you please also assist me, how to get “SECRET_KEY=super_secret_key_you_should_change”???

Thanks!

It’s okay Kanika :slight_smile:
Everything is now working.

Thank you very much…

1 Like