Error vagrant up

greetings, it’s the second time I’ve taken the course and wasted time at this very point with vagrant, apart from that is inefficient with connections of less than 2Mps, the provision this time is giving me an error with the gpg key, surely I can fix it, but it is something very annoying, I suggest you update and think about using another alternative for this, I suggest docker, lxc or even if you plan to continue using vagrant, create a custom box that can be used with kvm.

Here are the lines of the error:
mongod-m103: Install MongoDB Enterprise Repository
mongod-m103: + echo ‘deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse’
mongod-m103: + sudo tee /etc/apt/sources.list.d/mongodb-enterprise.list
mongod-m103: deb [ arch=amd64 ] http://repo.mongodb.com/apt/ubuntu trusty/mongodb-enterprise/3.6 multiverse
mongod-m103: + sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv 0C49F3730359A14518585931BC711F9BA15703C6
mongod-m103: Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.0fFZYDuz5j --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv 0C49F3730359A14518585931BC711F9BA15703C6
mongod-m103: gpg:
mongod-m103: requesting key A15703C6 from hkp server keyserver.ubuntu.com
mongod-m103: ?: keyserver.ubuntu.com: Host not found
mongod-m103: gpgkeys: HTTP fetch error 7: couldn’t connect: Success
mongod-m103: gpg:
mongod-m103: no valid OpenPGP data found.
mongod-m103: gpg:
mongod-m103: Total number processed: 0
The SSH command responded with a non-zero exit status. Vagrant
assumes that this means the command failed. The output for this command
should be in the log above. Please read the output to determine what
went wrong.

Please try pinging, if you are able to connect.

If you are still facing so much issues with vagrant, you can setup on your own machine and here are the validation files that you will require: Download Validation files

Let me know if I can help more.

Kanika

Greetings, thank you for answering, I tell you that I resolved otherwise, edit the file provision-mongodb and added these lines

function update_apt(){
sudo apt-get update
sudo apt-get - and upgrade
sudo apt-get install -y dirmngr
}

and comment the line 63