Error in Windows 10 with Vagrant up

Error on running Vagrant up on Windows 10, see message. Please advise.

Thanks !
Ajai

Hi @ajaibhatnagar,

Please run vagrant up command from the directory where you have downloaded m103-vagrant-env handouts.

   m103-vagrant-env> vagrant up

Kanika


Getting error with Vbox Manage as shown in screen shot. Please advise.
Thanks !
Ajai

Hi @ajaibhatnagar,

Please try the following:

  • Enable virtualization in the BIOS.
  • Make sure you have Hyper-V turned off in Windows 10 For Windows 10: Press Windows key. Type “Turn Windows features on or off” Deselect checkbox next to Hyper-V. Select OK. Select Restart now.

Kanika

Sorry, but I am not sure how to enable virtualization in the BIOS.

Tried but got new error as in screen shot. Also Hyper-V was not selected earlier.
Also enabled Virtual Machine Platform as on 3rd screen.

Thanks.

Hi @ajaibhatnagar,

Found this on Google:

https://www.tutorialspoint.com/windows10/windows10_virtualization.htm

Kanika

I enabled virtualization, vagrant tried to connect, but timed out. Please review error message and advise.
Thanks !

The Vagrant config script may need a time out parameter. Please review screen shot.
Thanks !

Please try to increase the value and check
timeout error is misleading sometimes
Vagrant takes lot of resources.So make sure you have enough memory/cpu
config.vm.boot_timeout (integer) - The time in seconds that Vagrant will wait for the machine to boot and be accessible. By default this is 300 seconds.

Please check our forums with boot_timeout keyword.You may get some help

Thanks , but this parameter is not in the config script. Where do i add it and what value ?

Please add it and see
Increase to 500 or 1000
Course instructors can help you more on this
Please check this link also

Not able to up vagrant

Added time out parameter to vagrant file. Getting new error as displayed.
Vagrant.configure(“2”) do |config|
config.vm.boot_timeout = 1000
config.vm.box = “ubuntu/trusty64”
config.vm.box_check_update = false
config.vm.synced_folder “shared/”, “/shared”, create: true
config.vm.synced_folder “dataset/”, “/dataset”, create: true

config.vm.define “mongod-m103” do |server|
server.vm.provider “virtualbox” do |vb|
vb.customize [“modifyvm”, :id, “–cpus”, “2”]
vb.name = “mongod-m103”
vb.memory = 2048
end
server.vm.hostname = “m103.mongodb.university”
server.vm.network :private_network, ip: “192.168.103.100”
server.vm.provision :shell, path: “provision-mongod”, args: ENV[‘ARGS’]
end
end
Please advise.
Thanks.

image

added time to script below , but got error displayed.
Vagrant.configure(“2”) do |config|
config.vm.boot_timeout = 1000
config.vm.box = “ubuntu/trusty64”
config.vm.box_check_update = false
config.vm.synced_folder “shared/”, “/shared”, create: true
config.vm.synced_folder “dataset/”, “/dataset”, create: true

config.vm.define “mongod-m103” do |server|
server.vm.provider “virtualbox” do |vb|
vb.customize [“modifyvm”, :id, “–cpus”, “2”]
vb.name = “mongod-m103”
vb.memory = 2048
end
server.vm.hostname = “m103.mongodb.university”
server.vm.network :private_network, ip: “192.168.103.100”
server.vm.provision :shell, path: “provision-mongod”, args: ENV[‘ARGS’]
end
end
Please advise.

Just hanging now with increased time out.

Please advise.

Hi,
Thanks for your help earlier. Looks like i have made some progress. Despite the hanging, I forced closed windows and logged back in.

Got into the mongod-m103 but ssh did not work.

Please advise. Thanks!

A

lso getting error below with vagrant halt. Please review.

Thanks !

Please run vagrant up and vagrant ssh again in the same order.

Kanika

I did that, but it was hanging, I also ran ssh-config, which shows a log in error as displayed.


Please advise.
Thanks !

Vagrant ssh runs , but with the message below.

Vagrant halt comes up with the message below.