Error connecting via Compass - Non-Genuine MongoDB Detected

Hi everyone,

I’ve been reading other threads, but I could not find any similar message!

I have checked, and as I connect to http://cluster0-shard-00-00-jxeqq.mongodb.net:27017/ I got a message indicating: “It looks like you are trying to access MongoDB over HTTP on the native driver port.”

So connectivity seems to be ok, but as I connect I get a message: Non- Genuine MongoDB Detected. This server or service appears to be an emulation of MongoDB rather than an official MongoDB product.

I am quite surprised about the response! Has anyone encountered this error connecting?

Which version of compass you installed?
From mongo docs
https://docs.mongodb.com/compass/master/connect/

NOTE

Starting in MongoDB Compass 1.19, Compass displays a warning message when connected to non-genuine MongoDB instances as these instances may behave differently from the official MongoDB instances; e.g. missing or incomplete features, different feature behaviors, etc.

I am using MongoDB Compass 1.19.6.

The main problem is not the message. Under “My Cluster” I can see 0 DBS and 0 Collections.

I am getting an additional message on top of the window: “An error occurred while loading navigation: 'not master and slaveOk=false”: It is recommended to change your read preference in the connection dialog to Primary Preferred or Secondary Preferred or provide a replica set name for a full topology connection".

net%3A27017%202019-09-02%2000-54-06

Oh, I got it solved! After reviewing the parameters and the screenshot, I discovered the Replica Set parameter.

If I set the parameter to Cluster0-shard-0 I can connect. Otherwise, I get the error about Non-Genuine MongoDB.

I would recommend this parameter to be included into Lab 1.1 steps.

Best,
César

1 Like