Error "cannot translate opcode 2013"

Hello,

I am facing this error:

AssertionException handling request, closing client connection: 34348 cannot translate opcode 2013

Does anyone know a source where I can find further details what this can indicate? Or has anyone seen this error before? The server is on version 3.4.24

Regards,
Michael

Hi @Michael

I have not specifically seen this before, but it looks like the client is using an opcode not supported by that server version:

https://docs.mongodb.com/manual/reference/mongodb-wire-protocol/#request-opcodes

OP_MSG 2013 Send a message using the format introduced in MongoDB 3.6.

If the driver/client supports 3.4 then I would say that is a bug. Otherwise just a plain old driver mismatch.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.