encryptionKeyFile argument error clarification

While dbpath and logpath works fine with relative path.
The same do not occur with encryptionKeyFile.
I have tried use ~ and ./ notations.
The only way that finally i get running was using the full path.

Idk if this is really a error or not, but seems to me it is. So if it is the case, let me know please.

Don’t know if it’s an error. Personally I prefer passing full paths anyway; less chances of messing things up that way.

Didn’t worked for me either. I had to pass the absolute path for encryption file.

1 Like

Hi Wallas_F_49482,

I posed the question to the MongoDB team.

Answer

–fork changes the CWD [current working directory]. So it’s necessary to convert the relative paths into absolute paths.

So it seems that the way the server code converts the path for these parameters it isn’t able to convert the path from a relative location.

David

2 Likes

But relative path works fine with dbpath and logpath even with --fork. In the same command I’ve put relative path for both dbpath and logpath and the absolute path for encryptionKeyFile.

I agree, the way the server code coverts the path for these parameters should be consistent with the way it converts relative paths for other parameters - I will point this out to MongoDB

2 Likes