Does MongoDB Ruby Driver still use bson_ext if available?

I’m wondering that bson_ext gem is still used by mongo gem?

In an old version document, I found a mention.
https://api.mongodb.com/ruby/1.1.2/

$ gem install bson
And for a significant performance boost, you’ll want to install the C extensions:

However, in a newer version does not mention at all.
https://api.mongodb.com/ruby/2.5.3/
https://docs.mongodb.com/ruby-driver/current/installation/

But the current documentation instead points to https://github.com/mongodb/bson-ruby

1 Like

The C extensions were merged into bson-ruby as far as I can tell.

1 Like

@Jack_Woehr @alexbevi Thanks for your comments.

It seems that bson-ruby is safe to remove from Gemfile if newer version of mongo ruby driver.

1 Like

Also I found this, https://github.com/mongodb/bson-ruby/tree/master/ext/bson.
C extension is indeed a part of bson-ruby gem.

1 Like