Disable to authentication

After connecting to port 27000.i am disable to authenticate

You mean unable to authenticate?
What command you issued and what error are you getting?

Hi @Akash_gupta1,

Any update on this :point_down:

1.i am running the command mongod --port 27000
2. I don’t know how to enable authentication

Are you doing a lab or just trying something else?
What error you are getting after connecting to mongo?

Please refer mongo documentation for different options not clear or not covered in your lectures/videos


when i want to launch mongod with the --config command line option getting this error

Post screenshot of the whole IDE. You have an error in the config file. We must see it to hel you.

If you look at the examples in https://docs.mongodb.com/manual/reference/configuration-options/ you will that there is no quotes.

I am not sure but I think that you need a space after the colon.

Which lab are you doing?

M103:-
Lab: Configuration File

this is a worst lab ever seen i am unable to excute this lab i spend more than 10 days to solve this lab
please help

From the lab specifications, there is only 2 small requirements:

  • run on port 27000
  • authentication is enabled

Your configuration file is way too complicated for this lab. I suspect that you cut-n-paste this file from a post in one of the thread. Part of it refers to the old vagrant course. Start from scratch by removing everything from your current configuration file and concentrate only on the 2 requirements of the lab.