Deploying sharded Cluster LAB : having issue launching mongos

please find the code screenshot for your reference
sharding:
configDB: csrs/192.168.103.100:27004,192.168.103.100:27005,192.168.103.100:27006
security:
keyFile: /var/mongodb/pki/m103-keyfile
net:
bindIp: localhost
port: 27000
systemLog:
destination: file
path: /var/mongodb/logs/mongos.log
logAppend: true
processManagement:
fork: true

image.
even i tried with port 26000 still facing same issue
image

Please do not post the same question in multiple discussion thread.

Which thread has the resolution to this problem been posted on, as I have the same issue

i dont want to get this issue missed out as we are getting delayed responses.

I have found the solution - miss named configDB

can you help me identify the mistake if i made any in my command

Hi,

Sure, I will try to summarize my confusion as soon as I can

thanks for everyone who tried to help me out. I found that instead off local host i have mentioned the IP meant for vagrant environment which is why i couldn’t proceed further. Now i have rectified and resolved the issue.

Just for reference, @nakeeran_Saravanan is talking about this thread.

~ Shubham