Debian 10 Buster libcurl4

Hi Guys - having issues getting enterprise server installed on debian 10 buster, getting an error about the libcurl version. Anyone know how to get it to work? Details here:

The following packages have unmet dependencies:
mongodb-enterprise-server : Depends: libcurl3 (>= 7.16.2) but it is not installable
Depends: libsensors4 (>= 1:3.0.0) but it is not installable
Depends: libsnmp30 (>= 5.7.3+dfsg-1.7+deb9u1~dfsg) but it is not going to be installed
snmp : Depends: libsnmp30 (= 5.7.3+dfsg-5) but it is not going to be installed
Depends: libsnmp-base (>= 5.7.3+dfsg-5) but it is not going to be installed

apt install libcurl3
Package libcurl3 is not available, but is referred to by another package.
However the following packages replace it:
libcurl4