Couldn't open file C:/M103/m103-vagrant-env/base


Microsoft Windows [Version 10.0.17763.864]
© 2018 Microsoft Corporation. All rights reserved.

C:\Users\HP>cd.

C:\Users\HP>cd/

C:>cd C:\M103\m103-vagrant-env

C:\M103\m103-vagrant-env>vagrant up --provision
Bringing machine ‘default’ up with ‘virtualbox’ provider…
==> default: Box ‘base’ could not be found. Attempting to find and install…
default: Box Provider: virtualbox
default: Box Version: >= 0
==> default: Box file was not detected as metadata. Adding it directly…
==> default: Adding box ‘base’ (v0) for provider: virtualbox
default: Downloading: base
default:
An error occurred while downloading the remote file. The error
message, if any, is reproduced below. Please fix this error and try
again.

Couldn’t open file C:/M103/m103-vagrant-env/base

C:\M103\m103-vagrant-env>

what is this error

Hi @Naiya_69938,

Please make sure you have followed all the instructions mentioned in the course properly and you have not made any modification in any of the vagrant files.

Please run this command and share the output.

dir

Also, please run the commands mentioned below and share the output if you get any error.

vagrant init
vagrant up
vagrant provision

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Dear Shubham,
Directory of C:\MinGW\M103\m103-vagrant-env

26/11/2019 23:45 .
26/11/2019 23:45 …
26/11/2019 23:45 .vagrant
26/11/2019 23:45 3,081 Vagrantfile
1 File(s) 3,081 bytes
3 Dir(s) 1,916,514,918,400 bytes free

C:\MinGW\M103\m103-vagrant-env>vagrant init
Vagrantfile already exists in this directory. Remove it before
running vagrant init.

C:\MinGW\M103\m103-vagrant-env>vagrant up
Bringing machine ‘default’ up with ‘virtualbox’ provider…
==> default: Box ‘base’ could not be found. Attempting to find and install…
default: Box Provider: virtualbox
default: Box Version: >= 0
==> default: Box file was not detected as metadata. Adding it directly…
==> default: Adding box ‘base’ (v0) for provider: virtualbox
default: Downloading: base
default:
An error occurred while downloading the remote file. The error
message, if any, is reproduced below. Please fix this error and try
again.

Couldn’t open file C:/MinGW/M103/m103-vagrant-env/base

C:\MinGW\M103\m103-vagrant-env>vagrant provision
==> default: VM not created. Moving on…

C:\MinGW\M103\m103-vagrant-env>

this is the reply i have got an output.

Please try vagrant destroy instead of vagrant init
Then run vagrant up

Your latest snapshot shows a different dir path for vagrant-env?
Why it is under C:\MinGW
If nothing works clean up all dirs and download the zip file and try again from scratch

Dear Ramachandra,

Can you please list the instructions if you can:

  1. Download Vagrant

  2. Download
    3 download Virtual box

4 save the handouts for vagrant from the course

5 where to save these handouts and how to run in CMD?

I would really appreciate your help.

Thank you

Naiya

Please follow your lecture notes.Latest Instructions should be there on how to setup
Handouts are attachments containing data dumps,validation_scripts etc
Just click on it.By default it downloads to your downloads directory(assuming you are on Windows)
Copy it to the directory where you need to install
If it is a zipped file you may have to unzip it
Check below link for reference only.Over course of time it would have changed

Installing, Setting up Vagrant and Run Validation Scripts

Course instructors can help you more if you are stuck with issues

Please help me to set up vagrant.

Hi @Naiya_69938,

Can you please provide some more information such as :

  • Host operating system and its version
  • Error message that you are getting while setting up vagrant

Thanks,
Shubham Ranjan
Curriculum Support Engineer