Connection Validation fails even though the api return data

Hi Guys,

The initial connection check is failing even after changing the connection string. Attached is the screeshot for the same. Please let me know if you have any solution.

Connection string: mongodb+srv://m200student:m200password@mflix.qmsl5.mongodb.net/sample_mflix?retryWrites=true&w=majority&maxPoolSize=5

Hi @Vikas_K_K,

I would recommend you to do the following steps:

  1. Login to your Atlas account and “Load Sample Dataset” again for your cluster. We need to do this in order to reflect the recent dataset changes in the cluster.

  2. Re-download the handouts and run the new M220N.sln file. Please ensure to keep the backup of all the code that you changed for the labs in the course and update the new project with your code.

Then try to attempt the Ticket: Connecting to Atlas.

Please feel free to reach out if you still get any errors.

Thanks,
Sonali

1 Like

Thanks Sonali,

That worked. I recreated the cluster, loaded the sample data set and used the latest sln from handout and replace the connection sting.

The connection integration test is working fine now.

Thanks & Regards,
Vikas

2 Likes