Connecting with the Browser IDE always fails

Hello,
so I’m unable to connect with the browser IDE but I was able to use nodejs to connect to the sandbox database. I’m using Firefox browser.

mongo "mongodb+srv://sandbox.xxxxx.mongodb.net" --username m001-student

It’s clearly mongodb’s fault not mine.

3 total, 0 passed, 0 skipped:
[FAIL] "Successfully connected to the Atlas Cluster"
[FAIL] "The cluster name is Sandbox"
[FAIL] "The username is m001-student"

Funny part, my cluster is named Sandbox, my username is m001-student.

You should be connected to your cluster when you run the test results
Since you are unable to connect it is showing all 3 test results failed

What error you are getting?
Have you pasted the command in the correct area of IDE
If yes have you hit enter?
Please show the screenshot how you ran the command

A word of wisdom, for your own sake avoid claims like

So, is the following your cluster URI?

Hi Damian_Toczek

You forgot to mention the database name in your URI. Use the following format or copy from Atlas.

mongo “mongodb+srv://sandbox.xxxx.mongodb.net/dbname” --username m001-student

Try authenticating using the “admin” database.
Hope this helps, if not please send the error which you get.

Just to let you know. The database name is optional in the URI. It defaults to test if not specified.

: steevej @ asus-laptop ; mongo mongodb+srv://m121:aggregations@cluster0-jxeqq.mongodb.net
MongoDB shell version v4.0.5
connecting to: mongodb://cluster0-shard-00-00-jxeqq.mongodb.net.:27017,cluster0-shard-00-01-jxeqq.mongodb.net.:27017,cluster0-shard-00-02-jxeqq.mongodb.net.:27017/?authSource=admin&gssapiServiceName=mongodb&replicaSet=Cluster0-shard-0&ssl=true
--- informational messages removed by steevej-1495 ---
MongoDB server version: 4.2.11
WARNING: shell and server versions do not match
MongoDB Enterprise Cluster0-shard-0:PRIMARY> 
MongoDB Enterprise Cluster0-shard-0:PRIMARY> db
test

The fact that it says that my cluster isn’t named Sandbox tells me that this Browser IDE is just broken. I mean, I’m able to use nodejs to connect but I’m unable to use the Browser IDE to connect? What logic is that? I’m following instructions that doesn’t work.

As already mentioned:

If you are not connected to your cluster. The validation script cannot know the cluster name. Since you got

The we know you are not connected. The other 2 tests will fail.

A screenshot of the following, in addition to the one asked by @Ramachandra_37567, will be useful.

The logic is that you might think that

but you either

  1. used the wrong connection string
  2. entered the command in the wrong area
  3. or like some, forgot to type [ENTER] at the end of the command

A screenshot will tell us which of the above 3 is your error.

Your error is number 3:

And also number 1:

The URI mongodb+srv://sandbox.xxxxx.mongodb.net is definitively not a URI that was given to you in Atlas.

In which part of the guide did it ever say to type enter at the end?
What is this even for a stupid In browser IDE where you need to type enter.

How is that URI wrong?

You are right. I guess they wrongly assumed that anyone experienced enough to want to learn a database system knows that you have to type [ENTER] at the end of a command. Even in Windows cmd.exe you need to do it.

Just so that you are aware, in the mongo shell you need to press [ENTER] at the end of the command, even if it is not mentioned anywhere.

For your entertainment see another case of wrong assumption from the designers at where is the any key - Google Search.

xxxxx is a place holder that shows the general format of a URI. And a place holder is defined as:

What is Placeholder Text?.

The Atlas connect button will tell you the URI of your cluster.

All this make me curious at what were you able to accomplish in NodeJS with the xxxxx URI.

The important is that you knew and did the correct thing.

I am sorry but I really did not see that you did. Can you indicate me in which post you did that? May be it was edited out and I missed it because I do not read the editing history.

If others are like me, @Ramachandra_37567 and @Santiago_Miranda are good at that, they know it is pointless to repeat a possible solution many times. It is really annoying, to see 2 or 3 posts repeating the same recommendations. It slows everybody as we have to read useless posts.

1 Like

Yes, I haven’t participated on this post but read it through.

I guess most of the times I’m more confused than certain so I know it’s also frustrating on the other side.

In my humble opinion, the OP needs a little guidance from the Dev Associates, they can check there is actually a cluster running etc. Maybe it shutdown for some awkward reason. I don’t know.

Another option @Damian_Toczek is a fresh start. Either using a different email or just re-launching a cluster, etc. Also including the exact URI that you see when pressing connect would be helpful.

Please remember that, although tends to be a bit dry sometimes :joy:, @steveej-1495 is trying to help you for free, and is normally correct on the assumptions.

Maybe someone like @yulia_genkina can better help you out.

Have a good day!

1 Like

Agreed, but if the Mongo team sees that people are constantly talking about it, maybe it would be a good idea to say explicitly that this Terminal works like a normal terminal and you must PRESS enter at the end and type your password.

The videos are great and I have also tried Treehouse for 2 months for free and thats why I got confused here.

Hi @Damian_Toczek,

Thank you so much for your feedback. We do see these posts and are working on updating instructions to increase the number of places where we say how the in-browser IDE works. We’re also working to improve the overall IDE usability for all of our users.

We are sorry for the frustration that you have experiences, but please do stay cordial while using this forum.

@Santiago_Miranda thank you for tagging me on this thread, and for your kind support of this community.

@steevej-1495 thank you for your patient and kind support of our user community.

3 Likes