Connecting compass to atlas cluster sandbox

While using compass to connect to my sandbox i used Cluster0-shard-0 as my replica set and it connected successfully.
I would like to know if there is a way i can use to know my replica set? because this one i just assumed things. For future connections, kindly.

Top left corner in Compass, you should see all the nodes within that replica set.

Hi @Anthony_Mulweye,

In addition to @007_jb,

You can also log into your Atlas account and click on your cluster name and it will take you to the Overview page where you can see all the nodes running in your replica set. There are some additional informations available as well such as which node is the primary and which one is secondary.

Hope it helps!

If you have any other issue, please feel free to get back to us. Happy Learning :slight_smile:

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Hi @007_jb,
Hi @Shubham_Ranjan,
Thank you guys for your help, you are so supportive.
I believe you guys will take me a distance as i keep learning and getting more insight.

@Shubham_Ranjan & Team will.
I’m just a student like yourself :wink:

Hi
@Shubham_Ranjan,
@007_jb,
I’m trying to connect to atlas cluster through mongo shell but i get this error

i have used this connection string and i have my connection whitelisted to connect from anywhere, i dont know why i am getting much trouble, i hope i dont make you guys tired of my questions

No problem there @Anthony_Mulweye :wink:

Another poster is having a similar issue to you but I can see that there’s a slight difference in the error message. Try and include the --password parameter in the connection string.

Hi
@Shubham_Ranjan,
@007_jb,
Hey good people, I managed to connect my problem was that i was using the atlas account password instead of the database user password.
I am sorry.
Thanks alot

From where did you get that specific cmd command?
My command for connecting to the cluster is different.

@shubhamverma18
After logging in to your atlas account, click on the connect button of your cluster, then select connect with mongo shell and it will direct you to

on instruction 2, you copy the connection string and paste in your cmd.

Also, v3.4 is a different connection string:
image

@007_jb
Yes, i have noted that.

@Shubham_Ranjan @007_jb It turns out that I am able to connect via shell without VPN if I select version 3.4 string.

Weird! Possibly a bug with your shell version (which I think was 4.2) trying to connect to Atlas Cluster 4.0. using SRV. Maybe someone else with shell 4.2 can test your connection string. Add a note to your topic/thread.

@shubhamverma18 i there.

Could you please confirm where were you located when you trying to connect with cluster and in which region did you deploy your Atlas cluster? Your reply will be helpful. I am facing a similar issue and looking into answers.

Regards,
A. J.

@Anthony_Mulweye is not the guy you want because he was using the wrong credentials. It’s @shubhamverma18 you want.

I have also updated @shubhamverma18 thread. I hope he sees it and replies.