Configuration file

What should be the path What are the changes I should make in editor ?
Screenshot (7)

You are supposed to start with an empty file and modify to fulfill 2 simple requirements.

  • run on port 27000
  • authentication is enabled

It looks like you have copied a file from somewhere else because it contains a lot of stuff that is not supposed to be there.

1 Like

Did these work for you?
I don’t see any problem with my config file and when i start the server, it is showing no error but it’s not running at all.

How can you say it is not working?
Did you check ps -ef|grep mongo
Show us the screenshot where you ran and config file contents

Hi @shubham_khandgaure,

This :point_down:

Please refer our documentation if you need help with the options : Configuration file options

Hope it helps!

~ Shubham

Hi @Paullaster_Okoth,

Please share the information requested @Ramachandra_37567.

Thankyou for your guidance.I was able to solve the issue

Hi I edited the config file with to fulfill the 2 requirements and i got the error below. please advice

yaml has to be intended with spaces

1 Like

HI @Peter_Abah,

This :point_down:

Let us know if you are still facing any issue. Also, you can use any online YAML validation tool to validate your YAML syntax. I came across this one : https://codebeautify.org/yaml-validator

Hope it helps!

~ Shubham

Hi @Peter_Abah Could you tell me how you solved it? I have the same problem as you, even i tried my code in https://codebeautify.org/yaml-validator, in that page my code is valid but in my IDE is not valid

Show your config file
Indentation is important in YAML file
Try to remove empty lines or remove the line in error and retype with proper indentation
It will work

1 Like

Hi @Aracely_23723,

Please share the information requested by @Ramachandra_37567.

You can also refer our documentation to know more about the Configuration file options.

Hope it helps!

~ Shubham

Thank you guys , I’ve resolved the issue, the problem was the spaces

Hi @Aracely_23723,

I’m glad your issue got resolved. Feel free to get back to us if you have any feedback for us.

Thanks,
Shubham

Hi @Araceley_23723 sorry for the late reply, i was able to resolve the issue by using 3 spaces rather than “tab” to indent nested key -value pairs. below are screenshots from my ide result. i hope this helps out if you haven’t figured it out already. let me know if this was helpful. thanks

1 Like

Thanks @Shubham_Ranjan, i used 3 spaces and it worked just fine. i’ll keep the YAML validation tool in mind for just in case i run into similar events in the future.

1 Like

Hello,
Net command is unrecognised.Could you please let me know the issue