Child process failed ,exited with error number 1

i have change dir permission using chmod 600 , but still throughs an error(child process failed)

Did you try to run mongod without --fork as suggested?
It will throw error on your terminal and you can investigate from there
or check the mongod.log
Checking with just typing mongo is not correct method
This will connect to default port 27017 as you can see from your screenshot
Since mongod is not running on port 27017 it failed to connect
Once your mongod on port 27000 is up and running try to connect by giving --port option
Also do not include the params which are not needed
Do you need operationProfiling for lab/work you are doing now?

any query that takes 50ms or longer is logged (remember to specify this in the configuration file!)

i dont know how to set this configuration , once i searched about this in web , it shows that operatingProfiling .

can u suggest me solution for this

@Dhilip_28128 you’ve replied to this part :arrow_up: of @Ramachandra_37567’s post.

What about these two suggestions? :arrow_down:

i am getting new error

i resolved this error

Closing this thread as the issue has been resolved.