(Chapter 1: The Mongod Lab: Launching Mongod) niuv

hi
in the IDE i run:
1.mongod
2. mongod --port 27000
after he say no good ,where i worng ?

Hi @itamar_comidi,

Can you share the screenshot of the IDE with the error for a better understanding of your problem!!

Thanks
Kushagra

I have now refreshed the page and the questions in the IDE do not appear

user@M103# mongod
2021-05-26T07:11:45.604+0000 I CONTROL  [main] Automatically disabling TLS 1.0, to force-enable TLS 1.0 specify --sslDisabledProtocols 'none'
2021-05-26T07:11:45.617+0000 I CONTROL  [initandlisten] MongoDB starting : pid=309 port=27017 dbpath=/data/db 64-bit host=TvipRAzjphUWOlAu4q
2021-05-26T07:11:45.617+0000 I CONTROL  [initandlisten] db version v4.0.5
2021-05-26T07:11:45.617+0000 I CONTROL  [initandlisten] git version: 3739429dd92b92d1b0ab120911a23d50bf03c412
2021-05-26T07:11:45.617+0000 I CONTROL  [initandlisten] OpenSSL version: OpenSSL 1.1.1g  21 Apr 2020
2021-05-26T07:11:45.617+0000 I CONTROL  [initandlisten] allocator: system
2021-05-26T07:11:45.617+0000 I CONTROL  [initandlisten] modules: none
2021-05-26T07:11:45.617+0000 I CONTROL  [initandlisten] build environment:
2021-05-26T07:11:45.617+0000 I CONTROL  [initandlisten]     distarch: x86_64
2021-05-26T07:11:45.617+0000 I CONTROL  [initandlisten]     target_arch: x86_64
2021-05-26T07:11:45.617+0000 I CONTROL  [initandlisten] options: {}
2021-05-26T07:11:45.643+0000 I STORAGE  [initandlisten] wiredtiger_open config: create,cache_size=256M,session_max=20000,eviction=(threads_min=4,threads_max=4),config_base=false,statistics=(fast),log=(enabled=true,archive=true,path=journal,compressor=snappy),file_manager=(close_idle_time=100000),statistics_log=(wait=0),verbose=(recovery_progress),
2021-05-26T07:11:46.606+0000 I STORAGE  [initandlisten] WiredTiger message [1622013106:606684][309:0x7fb7ca5cdca8], txn-recover: Set global recovery timestamp: 0
2021-05-26T07:11:46.611+0000 I RECOVERY [initandlisten] WiredTiger recoveryTimestamp. Ts: Timestamp(0, 0)
2021-05-26T07:11:46.631+0000 I CONTROL  [initandlisten] 
2021-05-26T07:11:46.631+0000 I CONTROL  [initandlisten] ** WARNING: Access control is not enabled for the database.
2021-05-26T07:11:46.631+0000 I CONTROL  [initandlisten] **          Read and write access to data and configuration is unrestricted.
2021-05-26T07:11:46.631+0000 I CONTROL  [initandlisten] ** WARNING: You are running this process as the root user, which is not recommended.
2021-05-26T07:11:46.631+0000 I CONTROL  [initandlisten] 
2021-05-26T07:11:46.631+0000 I CONTROL  [initandlisten] ** WARNING: This server is bound to localhost.
2021-05-26T07:11:46.631+0000 I CONTROL  [initandlisten] **          Remote systems will be unable to connect to this server. 
2021-05-26T07:11:46.631+0000 I CONTROL  [initandlisten] **          Start the server with --bind_ip <address> to specify which IP 
2021-05-26T07:11:46.631+0000 I CONTROL  [initandlisten] **          addresses it should serve responses from, or with --bind_ip_all to
2021-05-26T07:11:46.631+0000 I CONTROL  [initandlisten] **          bind to all interfaces. If this behavior is desired, start the
2021-05-26T07:11:46.631+0000 I CONTROL  [initandlisten] **          server with --bind_ip 127.0.0.1 to disable this warning.
2021-05-26T07:11:46.631+0000 I CONTROL  [initandlisten] 
2021-05-26T07:11:46.633+0000 I STORAGE  [initandlisten] createCollection: admin.system.version with provided UUID: 5e094007-bad5-41e3-b2ee-44c97643dad3
2021-05-26T07:11:46.644+0000 I COMMAND  [initandlisten] setting featureCompatibilityVersion to 4.0
2021-05-26T07:11:46.651+0000 I STORAGE  [initandlisten] createCollection: local.startup_log with generated UUID: e1189847-51a1-4062-a566-20363689d8de
2021-05-26T07:11:46.662+0000 I FTDC     [initandlisten] Initializing full-time diagnostic data capture with directory '/data/db/diagnostic.data'
2021-05-26T07:11:46.663+0000 I NETWORK  [initandlisten] waiting for connections on port 27017
2021-05-26T07:11:46.711+0000 I STORAGE  [LogicalSessionCacheRefresh] createCollection: config.system.sessions with generated UUID: 9ba9c978-87c7-41e8-8c20-66050d7aa611
2021-05-26T07:11:46.726+0000 I INDEX    [LogicalSessionCacheRefresh] build index on: config.system.sessions properties: { v: 2, key: { lastUse: 1 }, name: "lsidTTLIndex", ns: "config.system.sessions", expireAfterSeconds: 1800 }
2021-05-26T07:11:46.726+0000 I INDEX    [LogicalSessionCacheRefresh]     building index using bulk method; build may temporarily use up to 500 megabytes of RAM
2021-05-26T07:11:46.728+0000 I INDEX    [LogicalSessionCacheRefresh] build index done.  scanned 0 total records. 0 secs

Hi @itamar_comidi,

Welcome to the MongoDB Community Forums,

First I will suggest you reset the IDE by clicking on RESET WORKSPACE.

So, according to the problem statement of the lab, you have to configure the mongod. Use this command:

mongod --port 27000

I hope it helps!!

Thanks
Kushagra

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.