Chapter 1: Authentication Installing Vagrant

When following point 5 of ‘installing vagrant’ in m310 it asks me for a password. What password is it requesting because I can not see a password in any of the notes. Can anyone maybe point me in the right direction for where to find this password?
Vagrant install

I don’t think the provisioning was complete. Can you show a screenshot of the vagrant up database command that you ran and its entire output.

It is going to be A LOT of screenshots. Because in CMD it first did installations which I am struggeling to see what it installed… I just basically followed the instructions in the notes of the lecture

Ah yes of course it would… lots of dependencies. Take one screenshot of the bottom and confirm which command you ran.

Do you mean a screen shot like this one?

I meant the last couple of lines of the vagrant up output.
Or let’s not worry about that and re-provision each machine again. Run the following commands in a new terminal (ensuring that you’ve cd’d to your m310-vagrant-env folder):

  1. vagrant destroy infrastructure -f
  2. vagrant destroy database -f
  3. vagrant up database
  4. vagrant ssh database
  5. mongo --version
    Step 5 is to confirm that mongodb installed correctly

Let me know how it goes and I’ll give you the rest of the steps for the infrastructure machine.

I followed everything up until vagrant up database where I got this error. Have not encountered this before.
image

Found this in the log above. How to I work around this to get it authenticated?

You need to fix a line in the provision-database file following this post:


Then restart from step 1.

What is the similar to this query for Windows? Because I am not running on Linux?

You will find the file I mentioned above inside your m310-vagrant-env folder. It’s one of the files that’s contained in the zipped file you downloaded from the course.

Basically, change this line —>
apt-get install -y mongodb-enterprise
to this line —>
apt-get install -y mongodb-enterprise --force-yes

You’ll append --force-yes to that line.

Apologies for the late repy. I have followed all the steps you have given. After that CMD requested an upgrade on the servers. I said yes thinking it will help me. but now It requests a Chef server URL as you can see in attached Screenshot. So I do not know where I went wrong.

I don’t know what exactly you’ve done to get to that screen because I can see that you’re already ssh’d into the machine. Can you share the screenshot of this statement “After that CMD requested an upgrade on the servers.” Or guide me through the steps you took with screenshots.

You’re most likely using an office laptop installed with Chef which handles any config changes.

I can not do anything on cmd because this screen is almost as if it is locked in. I followed this command apt-get install -y mongodb-enterprise --force-yes. Then afterwards it asked for system upgrade, it took about 3 hours and the n when it said “update complete” I pressed enter on my keyboard now I Am on the screen for a Chef server URL. I can try and close it to restart everything and start from scratch again. Acoording to the list you sent me above with the 5 steps if you think that might be the best option?

I just need to understand what exactly you did with this? What do you mean by you followed the command?

When I put in this command it prompted the enterprise installation. afterwards in promted an “server update” .and now I am with the current screen

You’re actually not meant to run the command. Can you show me a screenshot of your provision-database file.

Will I get the provision database file from running the Vagrant provision command?

From here --------->

It’s in this folder:
image