Chapter 1: Authentication Homework 1.1 - Wrong Version Mongod?

When attempting to start mongod, it appears that it’s already running, and the version is 2.4.9! Is this correct? Surprised it’s already running and that the version is so old. I did try to proceed with the homework with this version but I don’t think it’s compatible with the tasks given. Help!

This is the MongoDB version that comes with the database VM:
image

1 Like

v2.4.9 was already installed and running on mine.
I just pulled down a new instlall, now at db version v3.2.22. That worked for this lession. Hopefully it will for future ones as well.

Are you sure you’re using the vagrant box? You shouldn’t be doing any labs on your local machine.

1 Like

I uninstalled 3.2 and installed 3.6. Problem solved!

Hi @Victoria_91811, I’m really not sure why you’re needing to uninstall and install different versions of MongoDB.

The database machine that comes with the vagrant box is provisioned with the correct version that is required for this lab and the entire course. This lab requires that you ssh to the database virtual box and run the lab there. All labs in this course are run from a virtual machine, not the local machine and the MongoDB that is installed on your local/host machine has no bearing on the MongoDB that’s installed in the virtual machines:

1 Like
  1. I was responding to Mark, the topic starter
  2. I was talking about virtual machine for the class, not my local installations.
  3. version 3.2 is too low - as you may find out in one of the lectures in chapter 1.