Chapter 0: Introduction and Setup : Error during setup of "Python Library Dependencies"

Hi,

When I run pip install -r requirements.txt , I get the following error among other success messages:

(mflix) C:\Mongodb_M220P\mflix-python>pip install -r requirements.txt

ERROR: spyder 4.0.1 requires pyqt5<5.13; python_version >= “3”, which is not installed.
ERROR: spyder 4.0.1 requires pyqtwebengine<5.13; python_version >= “3”, which is not installed.
ERROR: pytest-astropy 0.8.0 requires pytest-cov>=2.0, which is not installed.
ERROR: pytest-astropy 0.8.0 requires pytest-filter-subpackage>=0.1, which is not installed.
ERROR: spyder 4.0.1 has requirement jedi==0.14.1, but you’ll have jedi 0.15.1 which is incompatible.
ERROR: spyder 4.0.1 has requirement qtconsole>=4.6.0, but you’ll have qtconsole 4.5.5 which is incompatible.
ERROR: spyder-kernels 1.8.1 has requirement jupyter-client>=5.3.4, but you’ll have jupyter-client 5.3.1 which is incompatible.
ERROR: pytest-astropy 0.8.0 has requirement pytest>=4.6, but you’ll have pytest 3.3.0 which is incompatible.


ERROR: Cannot uninstall ‘terminado’. It is a distutils installed project and thus we cannot accurately determine which files belong to it which would lead to only a partial uninstall.

Any guidance would be appreciate.

Thanks
Nusrat

Hi

The above issue has been resolved by doing a combination of the following -

  1. Uninstalled existing python package(s)
  2. Re-installed python packages of as per version mentioned in requirements.txt