Can't connect to cluster

Can’t connect to Our Class Atlas Cluster from the mongo Shell. First “-ssl” is “Error parsing command line: unrecognised option ‘–ssl’” but even if I just remove “–ssl”, then I get the following:

$ mongo “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/100YWeatherSmall?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --username m001-student --password m001-mongodb-basics

MongoDB shell version v4.0.7
connecting to: mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/100YWeatherSmall?authSource=admin&gssapiServiceName=mongodb&replicaSet=Cluster0-shard-0
2019-03-26T15:27:46.206+0000 I NETWORK  [js] Starting new replica set monitor for Cluster0-shard-0/cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017
2019-03-26T15:27:47.184+0000 W NETWORK  [js] Unable to reach primary for set Cluster0-shard-0
2019-03-26T15:27:47.184+0000 I NETWORK  [js] Cannot reach any nodes for set Cluster0-shard-0. Please check network connectivity and the status of the set. This has happened for 1 checks in a row.
2019-03-26T15:27:49.135+0000 W NETWORK  [js] Unable to reach primary for set Cluster0-shard-0
2019-03-26T15:27:49.135+0000 I NETWORK  [js] Cannot reach any nodes for set Cluster0-shard-0. Please check network connectivity and the status of the set. This has happened for 2 checks in a row.
2019-03-26T15:27:51.014+0000 W NETWORK  [js] Unable to reach primary for set Cluster0-shard-0
2019-03-26T15:27:51.014+0000 I NETWORK  [js] Cannot reach any nodes for set Cluster0-shard-0. Please check network connectivity and the status of the set. This has happened for 3 checks in a row.

It is not -ssl.Should be --ssl

I am able to connect.Are you able to ping the server?
May be network/firewall preventing your connection

C:\Users\ramrt>mongo “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/test?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics
MongoDB shell version v4.0.5
connecting to: mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/test?authSource=admin&gssapiServiceName=mongodb&replicaSet=Cluster0-shard-0
Implicit session: session { “id” : UUID(“25ca5116-35af-4e2e-859e-d27753de7795”) }
MongoDB server version: 3.6.11
WARNING: shell and server versions do not match
MongoDB Enterprise Cluster0-shard-0:PRIMARY> db
test
MongoDB Enterprise Cluster0-shard-0:PRIMARY>

So your command cut and pasted as, give this error:

Error parsing command line: unrecognised option '--ssl'

I also did a “mongo --version”, which produced this:

MongoDB shell version v4.0.7
git version: 1b82c812a9c0bbf6dc79d5400de9ea99e6ffa025
allocator: tcmalloc
modules: none
build environment:
    distarch: x86_64
    target_arch: x86_64

Please check this link

My version
C:\Users\ramrt>mongo --version
MongoDB shell version v4.0.5
git version: 3739429dd92b92d1b0ab120911a23d50bf03c412
allocator: tcmalloc
modules: none
build environment:
distmod: 2008plus-ssl
distarch: x86_64
target_arch: x86_64