Can't connect to Atlas using command given in lecture

I have been trying to connect to the Atlas with the command:

mongo “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/100YWeatherSmall?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics

However, it does not connect like it does in the lecture video. I noticed I keep receiving this message:

2020-01-08T21:48:26.110-0800 W CONTROL [main] Option: ssl is deprecated. Please use tls instead.

Has something changed? When I type show collections after this, nothing shows.Tried using some of the commands from the video after using the copy/past command given as well and nothing happens.

It’s a warning (W) message telling you that in your version of mongo 4.2, the --ssl option is deprecated. So in the connection string, you can replace --ssl with --tls.

Doing so resulted in:

MongoDB shell version v4.2.2
2020-01-08T23:03:53.659-0800 F - [main] exception: No digits
2020-01-08T23:03:53.662-0800 E - [main] exiting with code 1

Share a full screenshot that includes the command and the outputs.

Hi @Brian_47766,

You are getting this error because of the fancy quotes. Please edit your connection string to use straight quotes i.e. "" .

Or, alternatively you can use this connection string as well :

mongo "mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/100YWeatherSmall?replicaSet=Cluster0-shard-0" --authenticationDatabase admin --ssl --username m001-student --password m001-mongodb-basics

Hope it helps!

Please feel free to get back to us if you have any other query.

Happy Learning :slight_smile:

Thanks,
Shubham Ranjan
Curriculum Services Engineer

1 Like