Can't connect atlas cluster to mongodb compass

I’m trying to connect my atlas cluster to mongodb compass, but suddenly i can’t connect to mongodb compass and i got a notification like this

Capture

I’ve never change my setting, this is my setting and primary connection

2

3

can someone help me? I really appreciate the help given. Thank you

This one is a tuffy.

What you gotta do is close Compass and then open up your task manager Ctrl + Alt + Del
in the task manager find the Mongo Db GUI and end tasks.

Then log into https://www.mongodb.com/cloud/atlas
and select your cluster. and select the connect button. This will provide a sting you can copy. so copy it and add in the user password and open up compass. compass will detect this string and prompt for a connection. should work.

2 Likes

That would work for Bonifasius’ personal MongoDB cluster, but this appears to be about the shared student cluster. So your trick won’t work.

The problem is that the read preference is set to “primary”. Please switch it so “prefer primary” or one of the options with “secondary”. Then you can at least read again.

I had same problem. Windows reloading helped me.

I had the same issue following the video instruction also my Mongo Atlas gives an error message “{ status: 404,
message: “Document Not Found” }” when trying to click on the primary sandbox.
but trying the steps above helped :+1::+1: solve the issue thanks Shahid now I can connect and continue with the chapter