Cannot validate apparently successful import of jason file

I think that I successfully imported the JASON file /dataset/products.json.
The . products.applicationData exists but validation fails:

MongoDB Enterprise > use admin
switched to db admin
MongoDB Enterprise > show dbs
admin 0.000GB
applicationData 0.029GB
config 0.000GB
local 0.000GB
test 0.057GB
MongoDB Enterprise > use applicationData
switched to db applicationData
MongoDB Enterprise > show collections
products
MongoDB Enterprise > exit
bye
vagrant@m103:~ validate_lab_import_dataset Client experienced a timeout when connecting to the database - check that mongod is running on the correct port, and that your user was created with the correct settings. vagrant@m103:~

What am I dong wrong?

Thanks

Time is running out.

Have you checked what it says here?

Let’s see a screenshot of how you login, i.e. your mongo command. And/or how you authenticate.

Hi @Howard_84497,

Please share the information requested by @007_jb .

Thanks,
Shubham Ranjan
Curriculum Services Engineer

Here you go.

vagrant@m103:~$ mongoimport --port 30000 -u “m103-application-user” -p “m103-application-pass” --authenticationDatabase “admin” --file="/dataset/products.json"
–collection=“products” --db “applicationData”

2020-01-07T13:01:16.722+0000 connected to: localhost:30000

2020-01-07T13:01:19.708+0000 [#####…] applicationData.products 20.2MB/87.9MB (23.0%)

2020-01-07T13:01:22.708+0000 [##########…] applicationData.products 40.3MB/87.9MB (45.8%)

2020-01-07T13:01:25.713+0000 [################…] applicationData.products 59.8MB/87.9MB (67.9%)

2020-01-07T13:01:28.707+0000 [#####################…] applicationData.products 79.9MB/87.9MB (90.9%)

2020-01-07T13:01:29.815+0000 [########################] applicationData.products 87.9MB/87.9MB (100.0%)

2020-01-07T13:01:29.816+0000 imported 516784 documents

vagrant@m103:~$ validate_lab_import_dataset

Client experienced a timeout when connecting to the database - check that mongod is running on the correct port, and that your user was created with the correct
settings.

vagrant@m103:~$

MongoDB Enterprise > show dbs

admin 0.000GB

applicationData 0.029GB

config 0.000GB

local 0.000GB

test 0.057GB

MongoDB Enterprise > use applicationData

switched to db applicationData

MongoDB Enterprise > show collections

products

MongoDB Enterprise >

Thanks. I think I’m doomed, on the last thing too.

Got to go to doctor appt in 2 hours.

Howard

(Attachment command.txt is missing)

Hi @Howard_84497,

Please remove the mongoimport command from your post.

Please change the port to 27000.

Hope it helps!

Thanks,
Shubham Ranjan
Curriculum Services Engineer

Here you go

vagrant@m103:~$ mongoimport --port 30000 -u “m103-application-user” -p “m103-application-pass” --authenticationDatabase “admin” --file="/dataset/products.json"
–collection=“products” --db “applicationData”

2020-01-07T13:01:16.722+0000 connected to: localhost:30000

2020-01-07T13:01:19.708+0000 [#####…] applicationData.products 20.2MB/87.9MB (23.0%)

2020-01-07T13:01:22.708+0000 [##########…] applicationData.products 40.3MB/87.9MB (45.8%)

2020-01-07T13:01:25.713+0000 [################…] applicationData.products 59.8MB/87.9MB (67.9%)

2020-01-07T13:01:28.707+0000 [#####################…] applicationData.products 79.9MB/87.9MB (90.9%)

2020-01-07T13:01:29.815+0000 [########################] applicationData.products 87.9MB/87.9MB (100.0%)

2020-01-07T13:01:29.816+0000 imported 516784 documents

vagrant@m103:~$ validate_lab_import_dataset

Client experienced a timeout when connecting to the database - check that mongod is running on the correct port, and that your user was created with the correct
settings.

vagrant@m103:~$

MongoDB Enterprise > show dbs

admin 0.000GB

applicationData 0.029GB

config 0.000GB

local 0.000GB

test 0.057GB

MongoDB Enterprise > use applicationData

switched to db applicationData

MongoDB Enterprise > show collections

products

MongoDB Enterprise >

Thanks

I think I’m doomed.

Doctor’s apt at 10 AM

Howard

Hi @Howard_84497,

Did you check the post #5 ?

You are running your mongod instance on incorrect port i.e. 30000.

In order to complete the lab, please run it on port 27000.

Thanks,
Shubham Ranjan
Curriculum Services Engineer

Thanks. Did the trick.

Thanks again!!

Great course.

Howard

Thanks. At this point I was pretty frantic and didn’t think to look. I will in the future.

Howard