Cannot run the script to load M121 course into my MongoDB server 4.2

Obtaining this error message when sending the command line: mongo “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/aggregations?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

---------- Messages shown on terminal - Running on MacOS ------------

Last login: Thu Sep 19 23:16:33 on ttys000

(base) MBP-de-Patrick:~ plangevin$ mongo “mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/aggregations?replicaSet=Cluster0-shard-0” --authenticationDatabase admin --ssl -u m121 -p aggregations --norc

2019-09-19T23:17:09.262-0400 W CONTROL [main] Option: ssl is deprecated. Please use tls instead.

MongoDB shell version v4.2.0

connecting to: mongodb://cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017/aggregations?authSource=admin&compressors=disabled&gssapiServiceName=mongodb&replicaSet=Cluster0-shard-0

2019-09-19T23:17:09.402-0400 I NETWORK [js] Starting new replica set monitor for Cluster0-shard-0/cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017

2019-09-19T23:17:09.402-0400 I CONNPOOL [ReplicaSetMonitor-TaskExecutor] Connecting to cluster0-shard-00-02-jxeqq.mongodb.net:27017

2019-09-19T23:17:09.403-0400 I CONNPOOL [ReplicaSetMonitor-TaskExecutor] Connecting to cluster0-shard-00-01-jxeqq.mongodb.net:27017

2019-09-19T23:17:09.403-0400 I CONNPOOL [ReplicaSetMonitor-TaskExecutor] Connecting to cluster0-shard-00-00-jxeqq.mongodb.net:27017

2019-09-19T23:17:09.572-0400 I NETWORK [ReplicaSetMonitor-TaskExecutor] Confirmed replica set for Cluster0-shard-0 is Cluster0-shard-0/cluster0-shard-00-00-jxeqq.mongodb.net:27017,cluster0-shard-00-01-jxeqq.mongodb.net:27017,cluster0-shard-00-02-jxeqq.mongodb.net:27017

Implicit session: session { “id” : UUID(“14124a67-044d-4184-a2c1-dd43906013ba”) }

MongoDB server version: 3.6.14

WARNING: shell and server versions do not match

MongoDB Enterprise Cluster0-shard-0:PRIMARY>

It tells me that my shell and server do not match. I had installed version 4.0 and changed all the binaries in my bin folder to the 4.2 version. Deleted them all and moved the latest versions.

Hi @Patrick_45742,

You can ignore both these warnings for the purpose of this course and move forward with the course.
Please let me know, if you have any questions.

Thanks,
Sonali

Sorry my bad. It worked, just thought it was not. Thanks.