Cannot install multiple editions (MongoDB Enterprise)

conflict

After getting this message I searched my entire machine for any older edition, and I thought I had removed all I could find, then rebooted, but still: I keep getting this error.

Please check if this helps

Thank you @Ramachandra_37567; unfortunately, it does not help. I cannot find any other MongoDB server. What I’ve got installed is MongoDB Compass. Should that be removed too?

As per mongo docs there is a parameter to exclude compass for msiexec.exe installation

To suppress the installation of MongoDB Compass, you must explicitly include the SHOULD_INSTALL_COMPASS="0" argument.

https://docs.mongodb.com/manual/tutorial/install-mongodb-enterprise-on-windows-unattended/