Can not connect to m320-96m7e.mongodb.net? Please help

I just started the course and simply can not connect to “m320-96m7e.mongodb.net” using Compass. How to resolve it?

First, don’t panic. I’m on chapter 3 and I haven’t yet needed to connect to that cluster :slight_smile:

Second, are you trying to connect from within your employer’s network? If so then your employer’s firewall may be blocking the request, and depending on how kafkaesque your employer’s process is for making changes to firewall rules, it may well be a lot quicker to do the course from your personal device, outside of your employer’s network (that’s what I’m doing).

Third, please post a screenshot of the connection settings that you’ve provided to Compass (assuming that’s what you’re using) and the error message that it returns. This will help people who are far more knowledgeable than me in this subject to understand what’s wrong.

[Edit]

Fourth (should really have been second, but that’ll mess up the numbering), have you previously been able to connect to an Atlas cluster from the device that you’re using?

Good luck :slight_smile:

1 Like

Could not connect to MongoDB on the provided host and port

Can someone help me with this issue

@Akhil_Kumar_Reddy_68114, same questions to you - without the answers to my questions above, even the cleverest of connection troubleshooters won’t be able work out what’s wrong.

2 Likes

The copy link is having ‘http://’ pre embedded with URL. Try removing http and give it a try, if have not tried this.