Can anyone tell me what's going on here with my mongo shell - because it's getting very old

This question isn’t specifically related to the M121 content, but because I’m encountering it in the work from this course, I decided the most appropriate place for it was here.

I’m happily (and carefully) typing my query parameters into the mongo shell, and then all of the sudden every character that I type is creating a new line. It’s happened so many times now that I’m being VERY careful about my typing (and I’m a very good typist anyway).

The point to look at here is at the end where the query on “genres” begins. I thought that the issue was maybe related to the size of the cmd window, but it doesn’t seem to be. Thanks for any help.

It’s definitely a terminal issue and it’s also overlapping on previous lines:


Try a couple of things:

  1. Use Powershell instead of Command Prompt to see if you get the same behaviour
  2. Right click the title bar on Command Prompt > select Properties > select Terminal tab > tick Disable Scroll-Forward > hit OK. Now test it on this same terminal window.

Can you share screenshots of all the tabs except the Colors tab.

Thanks jb. Here are the tabs. I’m coming back from a few days hiatus, so I’ll update if the Disable Scroll-Forward did the trick.

image
image
image
image

Update: There have been no further problems, so I think that “Disable Scroll-Forward” must have been what I needed. Thanks @007_jb

1 Like

Good to hear! Let us know if it goes back to its old ways.

You probably already know this, to make it permanent, apply the same setting to Defaults:
image