Auth not Enabled?

My .conf file appears correct, yet when I run the test it fails for Authentication???
sh-4.4# mongod -f ./mongod.conf
2020-08-29T12:52:49.815+0000 I CONTROL [initandlisten] options: { config: “./mongod.conf”, net: { bindIp: “localhost”, port: 27000 }, security: { authorization: “enabled” } }

image

3 total, 1 passed, 0 skipped:
[PASS] “The server is running on localhost:27000”
[FAIL] “The server requires authentication”

Don’t forget to launch mongod with authentication enabled!

What am I missing???

Thank you,
John

Have you completed all the steps?
Please review the steps again

Thank you… thought I could test the first part before adding the user; guess that was an incorrect assumption. The unit test must use the user account for testing… my bad! Thank you much.

Hi @John_Thomason,

Yes, the lab will fail if any of the requirements mentioned in the lab is not satisfied.