Atlas Doesn't show replica sets in the connection string

Atlas connect doesn’t show replica set nodes in the connection string. I had to manually get it from the metrics tab.

Connection String: mongo “mongodb+srv://sandbox-mvk3b.mongodb.net/test” --username m001-student

Replica set :

Please advise if there is any settings I am missing

When you have an SRV connection string you do not need to know the nodes. That’s the beauty of this innovation. You connect with the SRV URI and that’s it. The topology of the cluster is transparent to the application.

1 Like

Which means I dont have to supply --ssl and --authenticationDatabase flags too?

Got this link - https://www.mongodb.com/blog/post/mongodb-3-6-here-to-SRV-you-with-easier-replica-set-connections