Am offered only the connection string option for connecting to shell, no scroll down

When I click connect from the following:

image

note that this is a sandbox cluster, but is called cluster 0, not sandbox. I must have missed the option to change the cluster name. (Another background problem, since I had a logon for my company atlas, my business email login would not give me the choice of creating a cluster, given the new ‘integrated’ atlas services, so I had to use my personal email to get a free sandbox cluster. )

I then get something different from the lecture:

image

This gives me the choice of connecting with the mongo shell, which is the choice I took. The result looks like this:

image

Only a connection string, no other method available. Of course, this connection string looks quite different from the URI connection string in the lecture. I do wonder if I am entirely in the wrong place.

Hi @William_Frank_90755, on this screen, select different Mongo Shell versions and you’ll see the connection string change.
image

Hi @William_Frank_90755,

In addition to @007_jb,

I’m glad you were able to create your free atlas cluster. Now, I would recommend you to go through this Lab: Create an Atlas Sandbox Cluster again for getting the instructions to make some additional changes that you are required to do in order to be able to follow along in this course.

As I can see in the screenshot, the username is not being auto filled in your connection string, please make sure you have created a user in your cluster.

Hope it helps!

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Thanks, this helps in that it explains why course connection string is different from the current 4.2 shell.

Thanks as always Shubham. I plan to try to completely close down my current atlas cluster and start fresh.

Is there any way, By the way, to start a free atlas cluster with my company’s mongo altas servoce. using the new “unified login experience”. I could not find a way, and this is what lead me to use my pesonal email adress. Using my company address, Mongo Atlas tells me address already in use, and I can’t reregister with it.

Shuban, another question about this. I have TWO users of my sandbox 001 cluster. One of these users has the username and password for compass (with read and write permissions), the other one has a username and password I invented (with admin permissions). I imagine I should eliminate one of these. (I should not have tried to do this so late at night!)

Wm

Hi @William_Frank_90755,

Yes, now Atlas has a unified login experience that gives you access to MongoDB Cloud, Support, and Jira with a single identity.

Is there any specific reason why you want to terminate this cluster because if you have configured all the settings correctly as described in this Lab: Create an Atlas Sandbox Cluster, you should not have any difficulty in progressing through this course.

You can totally create a free tier atlas cluster using your business email. If you are already registered then simply log into your account by using your credentials that you have used for some other services that are part of the unified login experience.

There is nothing wrong with having two users and I believe you can keep both of them if it serves any purpose to you. The only thing is that if you have more than one user then the username would not get auto filled in the connection string.

But that’s not a problem. You can simply use the -u parameter to append the username at the end of your connection string.

Hope it helps!

If you have any other query, please feel free to get back to us.

Happy Learning :slight_smile:

Thanks,
Shubham Ranjan
Curriculum Support Engineer

Thanks so much.

I have connected my sandbox cluster to the mongo shell, using the sandbox I created with my private email. The results match the results in the lecture. Looks like it is working just fine, even with a different cluster name. I eliminated the second user, so all the authentication fields would auto-filll.

Whew!

I did not use my company email or my company atlas, because 1/it seems that my browser is using context of my last connection to make it hard for me to switch and 2/ in my company atlas, I can’t see how I can create a new free cluster. Maybe I don’t have the right priveleges – read & write, not admin. I will ask my compatriots about this.