2 out of 3 databases show up(No Video database), Connecting to Your Sandbox Cluster from Compass

image

image

Did you load the file loadMovieDetailsDataset.js into your sandbox cluster?
After that you will see video DB
As i mentioned before please ignore those warning messages
Please do these steps
1.connect to your sandbox
2.at mongo prompt run db and show dbs(you will see default DBs)
3.load the .js file
4.run again show dbs
5.you should see video in addition to admin and local DBs

1 Like

Thanks, I just saw your reply.
image

I’m unable to load the loadMovieDetailsDataset.js
I’m getting error stating that ‘load’ is not recognized as an internal or external comand. please help me

Looks like you are running load command at Windows cmd prompt
Run it at mongo prompt as below
cd to the dir where the .js file is residing
connect to your Sandbox cluster
MongoDB Enterprise Cluster0-shard-0:PRIMARY> load(“loadMovieDetailsDataset.js”)
true--------->indicates success

1 Like

Hi @ravali_reddy,

This :point_down:

~ Shubham

I have tried as you said i have conned to my sandbox cluster and i have tried to load . I’m getting error saying that error loading the .js file. Please help me

You have to run the load command in the same directory where the .js file resides. Alternatively, you may specify the full path to the file.

Hi @ravali_reddy,

In addition to @steevej-1495,

Please run dir command before you run the mongo command so that we can see the files present in this directory.

~ Shubham

image.png

Please exit mongo prompt and show us the path and contents of your dir

There are syntax errors in your load command.Right bracket is missing

Try double quotes if single quote is not working

As mentionnend earlier.

Hi @ravali_reddy,

I hope you found @Ramachandra_37567’s and @steevej-1495’s response helpful.

Please let us know if you are still having any issues.

~ Shubham