1.3 No such file or directory member1.pem

mongod logfile:
cannot read certificate file: /home/vagrant/member1.pem
No such file or directory

definitely have a file of that name in the shared folder…also a file of that name in a folder named ‘certs’ which I manually created within the shared folder as I wasn’t sure how to interpret the homework instructions…

my infrastructure issues are like a ball & chain …

This for which lab?
On which box you tried to bring up mogod
Can you see the file by ls command
ls -lrt /home/vagrant/member1.pem
I think path is wrong as you have mentioned above file exists in shared dir

Should be /home/vagrant/shared/member1.pem
or
/home/vagrant/shared/certs/member1.pem
Please check again your command line params

which ‘box’ ?? …boy I don’t understand infrastructure…

c:/Users/MyName/M310/m310-vagrant-env/shared

(Win10)
I made the M310 folder and put the handed out folder m310-vagrant-env in there which included the shared folder
…the shared folder also holds:
.vagrant folder
provision-database
provision-infrastructure
Vagrantfile

inside the shared folder:
I took the ‘server.pem’ and copied renamed as member1
being unclear on the class instructions I also made folder ‘certs’ and put a copy in there too.

Per instructions: " Make sure to copy the certs folder directly to the m310-vagrant-env/shared folder. If the certificates are not in this location then your results will be incorrect."

007 tried to teach me this topic in the last class on path/directory - and I still don’t get it…

db & log path are: ~/M310-HW-1.3/r0
(this worked in the 1.2 hw)

the prompt where I launch mongod is:
vagrant@database:~$

so I changed path to pem file to be
~/shared/…
and this worked to launch the mongod…

1 Like